Fuel gauges not working

Post here if you want to discuss a topic specific to the MV/32, MV/34, and MV/41.
Wbr2974
deckhand
deckhand
Posts: 23
Joined: Sat Feb 25, 2017 5:20 pm

Fuel gauges not working

Postby Wbr2974 » Thu Aug 16, 2018 4:03 pm

I’m just recently getting back to the boat starting to get ready for the Bahamas this winter and today decided to take on some fuel and pump out. When I started the boat I have no power at the gauges? There used to be a light that would come on and they were pretty accurate but today nothing at all. I tested the back of them and get no reading at all. Granted it’s still a new boat to me so am I doing something obviously wrong?? Both gauges have nothing so I can’t see the sending units dying at the same time...
On a side note I made a awful mistake filling the aft tank.. I left the sliding door open and the tank overflowed shooting a giant fountain of diesel all over the place and inside the boat everywhere. Not a pleasant experience at all....

Bill
MV 34
075

AlanH
skipper
skipper
Posts: 62
Joined: Mon Apr 25, 2016 3:55 pm

Re: Fuel gauges not working

Postby AlanH » Thu Aug 16, 2018 4:28 pm

Bill,

On our boat, the fuel gauges come on from a breaker on the DC sub panel labeled instruments. Was it on? If so, I would check to be sure there is power coming out of the breaker.

On the fuel spill, it can be a challenge to not get some spitting when filling our boat. I try to really slow the pump when getting withing 10 gallons of my estimate for what it will take. I also listen very carefully to the sound of the fuel going in. There is usually a bit of a change at the last second. I have considered the purchase of a product called Clean Way Fuel Fill. I don't know anyone using it and I am not committed jet. Here is a link if you are interested. https://cleanwayfuelfill.shop/

Alan
AlanH
Catbo
2006 34' Hull #81
75hp engines

Wbr2974
deckhand
deckhand
Posts: 23
Joined: Sat Feb 25, 2017 5:20 pm

Re: Fuel gauges not working

Postby Wbr2974 » Thu Aug 16, 2018 5:27 pm

Alan,

On my 05 the instrument breaker also controls the chart plotter and yes it was on. In fact I turned them all on just to make sure yet I still get nothing to the gauges??? Normally when fueling I keep an eye on them and when I get close I start slowing down big time but I couldn’t remember how much I used coming from Stuart to key largo (about 50 gal) I’m not sure what to check next but that clean fuel thing you sent me is already on the way.
Something like that should be mandatory and the marinas should provide them. Has to be cheaper than all the oil absorb pads they use....
I’m guessing someone must have had a problem with fuel gauges at sometime?
I’m still betting on user error...
Thanks
Bill
MV 34 075

James Power
admiral
admiral
Posts: 221
Joined: Tue Apr 01, 2008 3:30 pm
Location: Georgian Bay

Re: Fuel gauges not working

Postby James Power » Thu Aug 16, 2018 10:15 pm

Hey Bill,
With the instruments on check the back of the gauge for power. If present try jumping the center terminal on the tank sender to the tank itself. If the gauge pegs to full then the gauge is good but sender may be defective.

James

Wbr2974
deckhand
deckhand
Posts: 23
Joined: Sat Feb 25, 2017 5:20 pm

Re: Fuel gauges not working

Postby Wbr2974 » Fri Aug 17, 2018 8:06 am

James,

With the instrument breaker on I have checked for power to the gauges with a multimeter and get no voltage at all.
All other instruments are working normally.
I thought maybe the key needs to be on however that makes no difference still no power. Might there be a inline fuse somewhere that I am missing??
Thanks
Bill,
MV34 075

James Power
admiral
admiral
Posts: 221
Joined: Tue Apr 01, 2008 3:30 pm
Location: Georgian Bay

Re: Fuel gauges not working

Postby James Power » Fri Aug 17, 2018 10:26 am

Bill,

Typically there was no inline fuse installed on the fuel gauge circuit after the distribution panel breaker. There is a chance it has be rewired since the factory. Try following the power feed wire from the gauge back and see where it leads.

James

Wbr2974
deckhand
deckhand
Posts: 23
Joined: Sat Feb 25, 2017 5:20 pm

Re: Fuel gauges not working

Postby Wbr2974 » Sat Aug 18, 2018 2:19 pm

I’m happy to report my gauges are back up and running.
Having no power to the gauges I followed James advice and here is what I found.
The aft tank gauge is connected directly to the forward tank gauge.
So the power line for both gauges goes from the forward tank gauge to the
bus bar located directly below the forward tank gauge and there is indeed an
Inline fuse before it connects to the bar. 3 amp I believe. I replaced the fuse with the only one I had (5 amp). Turned on the instrument breaker and all works great.
Hope this may help someone else at some point..
Thanks for the help everyone !!!

Bill
MV34 075


Return to “PDQ Powercat Forum”

Who is online

Users browsing this forum: No registered users and 6 guests